User Tools

Site Tools


rt_systems

RT Systems

Background

Repeaterbook and RT systems entered into a partnership several years ago to open an API for importing Repeaterbook data directly into the RT Systems app. This means that anyone who owns a copy of the RT Systems software can choose parameters and import data directly into programming software.

There is no subscription required to access the Repeaterbook data from the software. The data import is absolutely free.

Alternatively, owners of RT Systems software can also conduct searches on the Repeaterbook.com website and export the search results into a file compatible with importing into the RT Systems programming software, regardless of the radio the application was intended for. Some users may require more advanced or customized search options that can only be conducted on the Repeaterbook.com website. This does require an intermediate step to save the file to your computer and then import it into the RT Systems application but improves flexibility.

Importing Directly into RT Systems

  1. Open the RT Systems Programming Software
  2. Click File » External Data » RepeaterBook Search
  3. In the location field, enter the center of the area to be searched. You can use a city and state, a city and country, a landmark, or a zip code. The program will use the Google Geocoding API to determine the coordinates for your queried location.
  4. Enter the radius to search
  5. Select the desired bands
  6. Click OK

The search results will open in a new tab. You can edit the list as you desire before writing the data to your radio. You can even use the copy commands to place some entries into another tab and create a more customized list or to add channels to an existing list. Please refer to the RT Systems documentation available with the software for more information.

Exporting from Repeaterbook

Repeaterbook.com offers many more search options than what is currently offered within the RT Systems software. If you don't mind a little more work an effort, you may be able to produce a more customized list of channels to write to your radio.

To produce an export file, you must first conduct a search for repeaters on Repeaterbook.com. The following searches currently offer the option to export the results in an RT Systems file format:

  • Quick Search
  • Advanced State Search (multi-state with filtering)
  • County Search (multi-county with filtering)
  • Proximity Search
  • Free Text Search
  • Call Sign Search

Once you save the file to your computer, open the RT Systems Radio Programming software and follow these steps:

  1. Click File » Import
  2. Choose the file on your computer and click Open

The repeater channels will display in a new tab within the RT Systems software.

rt_systems.txt · Last modified: 2019/02/10 16:24 (external edit)